rz2k has quit []
splatid has joined #cubieboard
splatid has quit [Client Quit]
n01 has quit [Ping timeout: 240 seconds]
msouth has quit [Quit: This computer has gone to sleep]
unixjazz has quit [Read error: Connection reset by peer]
<emx> this is what i get: mmcblk0: unknown partition table
<emx> do i corrupt the partition table by dding the uboot part?
wolfy has quit [Ping timeout: 252 seconds]
unixjazz has joined #cubieboard
lkoranda has joined #cubieboard
stefanro1 has joined #cubieboard
stefanro has quit [Ping timeout: 265 seconds]
nils_2 has joined #cubieboard
lkoranda has quit [Read error: Operation timed out]
lkoranda has joined #cubieboard
smccarthy has joined #cubieboard
lkoranda has quit [Ping timeout: 264 seconds]
lkoranda has joined #cubieboard
unixjazz has quit [Ping timeout: 240 seconds]
lkoranda has quit [Ping timeout: 260 seconds]
FRQuadrat has joined #cubieboard
FR^2 has quit [Ping timeout: 245 seconds]
FRQuadrat has quit [Quit: und weg...]
emx has quit [Ping timeout: 252 seconds]
lkoranda has joined #cubieboard
FourthDr has joined #cubieboard
TheSeven has quit [Disconnected by services]
[7] has joined #cubieboard
unixjazz has joined #cubieboard
kivutar has quit [Quit: Ex-Chat]
deasy has quit [Quit: Nom d'un quark, c'est Edmonton !]
lerc has quit [Ping timeout: 265 seconds]
kroylar has joined #cubieboard
lerc has joined #cubieboard
DEac-_ has quit [Read error: Connection reset by peer]
bizarro_1 has quit [Quit: Leaving]
madmaxx has quit [Remote host closed the connection]
smccarthy has quit [Remote host closed the connection]
eebrah has joined #cubieboard
Baronawesome has quit [Ping timeout: 240 seconds]
Baronawesome has joined #cubieboard
unixjazz has quit [Ping timeout: 240 seconds]
diffycat has quit [Ping timeout: 245 seconds]
shineworld has joined #cubieboard
eebrah has quit [Quit: Lost terminal]
ganbold_ has quit [Ping timeout: 264 seconds]
diffycat has joined #cubieboard
ganbold_ has joined #cubieboard
RA3OR has joined #cubieboard
n01 has joined #cubieboard
Cpt-Oblivious has joined #cubieboard
FR^2 has joined #cubieboard
makka has joined #cubieboard
RA3OR has quit [Read error: Connection reset by peer]
RA3OR has joined #cubieboard
kroylar has quit [Ping timeout: 264 seconds]
kludge` has quit [Ping timeout: 240 seconds]
kludge` has joined #cubieboard
shineworld has quit [Remote host closed the connection]
JohnDoe_71Rus has quit [Quit: KVIrc Insomnia 4.0.2, revision: 402, sources date: 20100627, built on: 2010-08-02 17:44:33 UTC 402 http://www.kvirc.net/]
makka has quit [Quit: WeeChat 0.4.2]
y0g1 has quit [Quit: brb]
y0g1 has joined #cubieboard
y0g1 has quit [Client Quit]
y0g1 has joined #cubieboard
y0g1 has quit [Client Quit]
y0g1 has joined #cubieboard
uizex1 has joined #cubieboard
<dashie> i've debian+xfce on my cubietruck but the cpufreq widget show it runs at 720MHz, it should be greater no ?
tpaper has joined #cubieboard
<Bushmills> depends on selected governor and load
<Bushmills> and along with those two, the max frequency the governor is allowed to switch to
<Bushmills> dashie: ^^
bizarro_1 has joined #cubieboard
<dashie> Bushmills: is there a howto for that ? it's the default config with ondemand gouvernor, it should pick the max freq available...
<Bushmills> i don't know about a howto. if not reading and writing to the corresponding pseudo files under /proc, you may want to install cpufreq-utils and read their man pages
rz2k has joined #cubieboard
<Bushmills> package name is actually cpufrequtils
<bfree> http://linux-sunxi.org/Cpufreq should help point you to the right files to look at to see the current settings and/or change them
hramrach has quit [Remote host closed the connection]
deasy has joined #cubieboard
mkad has joined #cubieboard
y0g1 has quit [Ping timeout: 272 seconds]
<mkad> does installing system on nand make it faster?
<mkad> its damn slow from sd card
y0g1 has joined #cubieboard
<mnemoc> get a better card :p
<mkad> mnemoc, well its a fast card
<mkad> I wonder if nand is faster
<mkad> than any card?
<mkad> or are some cards faster tha nand?
<mkad> or is FS on SATA the fastest ?
<ssvb> how do you measure performance?
<mkad> by opening website
<mkad> ^^
<mkad> not very relible
<mkad> but also by starting apps in shell
<mkad> like mc
<mkad> I dont know if its a disk... maybe just cubieboard is slow
<mkad> nevertheless I was wondering if hardware (media) where I have rootfs matters?
<mkad> I am running nginx web server + postgres + gunichorn application server, and ssh, all optimized for memory use.. I dont spawn too many workers etc..
<mkad> my internet connection is local
<mkad> and still mc starts pretty slow..
<y0g1> mkad: I run cubietruck (A20) with armedslack without optimizations and it is ok
<ssvb> mkad: try to first set the cpufreq governor to "performance"
<ssvb> is it a cubieboard1 or cubieboard2?
<y0g1> mkad: apache+ssh+bind+sshd+vsftpd+mldonkey+minidlna
<y0g1> mkad: and mysql
<mkad> cubieboard 1
<mkad> not 2
<mkad> if I could sample A20 or buy it only I would change chip myself with some hot air gun
<y0g1> mkad: ssvb is right - change governor to performance
<mkad> let me check
<mkad> apt-cache search takes ages...
<y0g1> mkad: I did changed governor to performance and it helped with faster loading wordpress sites
<mkad> oh
<mkad> does it overheat much more?
<mkad> cause mine is in plastic box...
<y0g1> mkad: I temp1: +39.4°C (low = -144.7°C, high = +264.8°C)
<mkad> and no cooling
<y0g1> mkad: I use small heatsink only (already to cubietruck included)
<mkad> I use cubieboard1
<mkad> wow that helps
<y0g1> mkad: but I will probably change it to something bigger
<mkad> it starts immedietly now
<y0g1> mkad: that is performance :)
<ssvb> mkad: there should be no big difference between "ondemand" and "performance" under heavy load, it's just that "ondemand" kills interactivity and makes the system laggy
<mkad> wow that helps with website as well
<mkad> ssvb, it helps a lot
<mkad> websites are not laggy anymore
<y0g1> ssvb: default governor was not ondemand but fancy
<mkad> mine default was on demand
<mkad> its Debian
<y0g1> ok
<mkad> somekind of custom rom
<mkad> I dont remember
<mkad> long time ago I was setting it up, and than it was off because it was too slow etc...
<ssvb> y0g1: the settings in sun4i and sun7i defconfigs are inconsistent :(
<mkad> mow much Watt it drains at full performance ?
<y0g1> I read that fancy react faster than ondemand, but in my case it was not enough fast. I have to use performance
<ssvb> the default is ondemand for sun4i and fantasy for sun7i for some reason
<mkad> I hope its not overheating ...
<ssvb> both of them are a poor choice if you are not running on a battery
<y0g1> ssvb: ok
<y0g1> ssvb: if you mention battery.. what for cubietruck has got battery connection?
<ssvb> there are no reasons not to use the performance governor if you are powering the device from a wall plug
<y0g1> ssvb: If I use sata hdd drive (3.5) with external 12V supply, then it will not work on battery?
smccarthy has joined #cubieboard
<y0g1> ssvb: If I replace 3.5"" disk with 2.5 and 5V supply then it should work with battery?
<ssvb> y0g1: don't know, I have not tried it yet
<y0g1> ssvb: ok, I will check it when I will change hdd drive
<y0g1> mkad: I read that A10/A20 are protected so they will just stop working when overheating without damage
<y0g1> ssvb: do You know how to setup cubietruck for autoboot on power restore? When I do shutdown -h now I have to use power button to run cubietruck but I don't have access to it
<y0g1> ssvb: I wish to have an option to boot system every power return
<mkad> y0g1, I guess you can sense battery level and put system into low power mode/sleep when battery is low... ? :P
<mkad> y0g1, also you are going to ruin your battery if you keep discharging it completly
<y0g1> mkad: I don't have battery now, but when I do some changes in cubietruck I need to shutdown it. I have cubietruck inside metal box and no access to power button. Each time when I want to start it I have to open the case, turn it on and close the case (4 screws)
<mkad> y0g1, so battery level measurement via balance leads is a good idea if you use LiPo
<mkad> y0g1, make a button in box ? ;)
<mkad> y0g1, anyways you should not discharge LiPo below 4.2V per cell
<mkad> otherwise they will die very soon
Wessix has joined #cubieboard
<mkad> and you should also find out C value:P
<y0g1> mkad: how? it is on pcb and I wont to replace it with external
<mkad> I dont think cubieboard can measure LiPo cells charge level
<mkad> you need to buy external unit or make one
<mkad> check hobbyking for ready circuits
<mkad> its cheap and you can modify it
<mkad> I use one for my quadcopter
<y0g1> mkad: I work for manufacturer of UPS units :) so no problems with it
<mkad> so I can land before battery drops too low
<y0g1> mkad: I just need to setup cubietruck to autoboot on power restore
<mkad> y0g1, you said something about using battery, so if you use LiPo, you should not drain too much current that it is rated for and you should not discharge it below ~4.0-4.2V level to extend its life time.
<mkad> y0g1, maybe thats useful info for you, I dont know
<y0g1> mkad: I would like to know if cubietruck can be setup to auto boot each time the power is back (even after shutdown -h now)
<mkad> y0g1, probably
<mkad> y0g1, if power button is pressed continously ?
<mkad> check that and if so,solder it pernamently
<mkad> :)
<mkad> but I dont take any resposibility for that
<y0g1> mkad: it will not work, when You power on cubietruck and then switch power on - then it will poweroff
<y0g1> mkad: it work as power button in atx power supply - bios shutdown the system when You release power button for long time
<mkad> oh
<mkad> than make a circuit for it with small relay :)
<mkad> or darlington
<mkad> :P
<mkad> or optoisolator
<mkad> or whatever;)
<mkad> mosfet I dont know... I am not electronics guy ;)
<y0g1> mkad: or.. maybe there is an option for it somewhere in nand/uboot or fex ?
<mkad> y0g1, momentary relay should turn on and release, as I read, but I am not sure never used one $2 prize
<y0g1> mkad: i prefer to use cubietruck without hardware modyfications
<mkad> two extra wires sticking out to relay arent a big modification imo... :P but yes check other options as mine ideas are a little bit harrash :)
<y0g1> mkad: http://linux-sunxi.org/AXP209 there is something about fex
<y0g1> mkad: in cubietruck spec there is info that Li-Batt should be 3V
<y0g1> mkad: and there is connector for external power button :) J11
<mkad> y0g1, smallest I know are 3.7V one cell.. there is no regulator ?
<mkad> RJ11 ?
<mkad> ah I see
<y0g1> mkad: something more. Power button is connected to AXP209, so if I will make proper setup for it it shoud start
<mkad> y0g1, does it need exactly 3V ?
<mkad> y0g1, you should see in AXP209 specs what is allowed?
<y0g1> mkad: I am not sure, on circuit there are two symbols, BATT 3V and BAT. I doln't know where to connect battery
<mkad> anyway... you might need UBEC to have stable 3.3V output, dont connect battery directly if you dont want to fry your cubie:)
<mkad> check circuit where the thing you connect your source goes
<mkad> schematics
<mkad> than check datasheet what is allowed on that pin
<mkad> :)
<y0g1> mkad: I will check, but it is hard from chinese spec
<mkad> fail
<mkad> y0g1, this guy got batteries that were overloaded (too much current drained) so they overheated and he used inefficieint regulator to have correct voltage ... wasting a lot of power
<y0g1> mkad: axp209 is for 3V batteries
<mkad> but cubie drains 2A ?
<mkad> :D
<y0g1> mkad: but there should be also connectors for temperature-sensitive resistor to use temperature monitoring function
<mkad> The Cubieboard requires a regulated 5V DC, 2A power supply with a 4.0mm (external diameter) x 1.7mm (internal diameter) barrel plug. The outside of the plug is the ground.
<mkad> A 500mA supply is sufficient if you do not attach a SATA hard disk to the Cubieboard.
<y0g1> mkad: I use 2.5A 5V adapter + 12V for sata
<mkad> I use SSD sata which does not need any extra power
<y0g1> mkad: in cubietruck there is no place for battery temperature sensor - they connected onboard 100R resistor
<mkad> so for me usb 3A hub and 5V is enough
<y0g1> hmm... I forgot that there is already lithium rechage 3V battery on board
<y0g1> and there is a place for BAT1/BAT2 Power source also, but there is no info what voltage for it
<y0g1> 3V is backup batt
<mkad> I am leaving/
<y0g1> me too
FourthDr has quit [Ping timeout: 245 seconds]
shineworld has joined #cubieboard
A124 has joined #cubieboard
A124 has quit [Remote host closed the connection]
A124 has joined #cubieboard
Wessix has quit [Quit: Nettalk6 - www.ntalk.de]
kroylar has joined #cubieboard
VargaD has joined #cubieboard
red723 has joined #cubieboard
Cpt-Oblivious has quit [Ping timeout: 248 seconds]
red723 has quit [Quit: Verlassend]
FourthDr has joined #cubieboard
uizex1 has quit [Quit: Life without danger is a waste of oxygen]
joph has left #cubieboard ["Verlassend"]
diffycat has quit [Read error: Connection reset by peer]
uizex1 has joined #cubieboard
datagutt has quit [Ping timeout: 245 seconds]
unixjazz has joined #cubieboard
nils_2_ has joined #cubieboard
nils_2 has quit [Ping timeout: 264 seconds]
nils_2_ is now known as nils_2
RA3OR has quit [Read error: Connection reset by peer]
n01 has quit [Remote host closed the connection]
madmaxx has joined #cubieboard
n01 has joined #cubieboard
<tomboy64> is there someone using usb harddrives with the cubietruck?
<tomboy64> or the cubieboard?
<tomboy64> i need some help identifying a pof
datagutt has joined #cubieboard
n01 has quit [Read error: Connection reset by peer]
n01 has joined #cubieboard
DEac- has joined #cubieboard
<mkad> tomboy64, I am not but whats wrong?
<DEac-> hi
<DEac-> i'm wondering, my cubieboard changed his mac since last time.
<DEac-> oh, it's normal...
<DEac-> why it it does?
<shineworld> you have to fixed it on uEnv.txt
<shineworld> so at any boot is same
<shineworld> otherwise is random
<DEac-> ah ok, i would set it via /etc/network/interfaces now.
tpaper has quit [Quit: Sto andando via]
<DEac-> shineworld: thanks
<shineworld> you are welcome
<shineworld> PS: if you are able to get CHIP ID serial (should be one) you can use it to get always different MAC for your boards
<shineworld> I've, in my board, an external chip with serial ID (UUID) which I use to create a virtual MAC for any board
<DEac-> chip id serial?
<shineworld> A10/A20 .... ID....
<shineworld> sometime ago someone tried to recover it at kernel level
<shineworld> I've left this way because I've a spi chip with a unique ID which I can use for that
<DEac-> ah, cpu-chip?
<shineworld> yes
<DEac-> i only want to use a fix mac because fix ips via dhcp.
rz2k has quit []
<shineworld> ok :)
<DEac-> what's the reason for random macs?
<Turl> DEac-: there's no mac stored on the hardware
<Turl> so if you don't configure one, it just puts a random one so it works
<shineworld> just the Allwinner CHIP don't have "purchased" a MAC for every chip
<shineworld> I guess...
hramrach has joined #cubieboard
<shineworld> In past we have purchased 1 thousand MACS and was expensive
<DEac-> lol. i didn't know, that's possible to purchase nics without a mac.
<shineworld> for eg: when I need a stack TCP/IP UDP fastly in low power CPU systems I use chips like Wiznet W5100 which don't have a proprietary MAC and you have to purchase one and config to use it...
D0pamine has joined #cubieboard
<shineworld> sorry mistake hundred with thousand... english is a bad beast for me
<DEac-> no problem, my english is not better. but 100 and 1000, that is a difference. (till now, i have no problems to understand you)
<shineworld> just take a look here : http://standards.ieee.org/develop/regauth/iab/
<shineworld> for 4096 ID you can spend a lot
n01 has quit [Remote host closed the connection]
<DEac-> ok, my next problem: nand-part. i've 3 partitions (bootloader 32768, size 131072) (rootfs 163840, size 4194304) and (UDISK 4358144, size 10584064). i do not know, what is this UDISK? i can not mount it. and how i can remove it and resize rootfs? i think, nand-part 32768 'bootloader 131072' 'rootfs 14778368'
RA3OR has joined #cubieboard
n01 has joined #cubieboard
RA3OR has quit [Read error: Connection reset by peer]
RA3OR has joined #cubieboard
<shineworld> android ?
<DEac-> no, lubuntu
<shineworld> sorry no matter for me :)
<shineworld> UDISK in android could be User Disk aka SDCARD partition bad I don't know in linux
<DEac-> android is a linux. ok, so it is android specific. i think, i can remove it. it seems to be broken.
DropBear has quit [Ping timeout: 246 seconds]
<shineworld> In android 4.2.2 we have:
<shineworld> # from to type name size
<shineworld> # ===== ========= ==== ========== ====
<shineworld> #nandb - mmcblk0p2 - emmc - env - 8000I SWITCH to ext4
<shineworld> # nanda - mmcblk0p1 - vfat - bootloader - 8000
<shineworld> # nandc - mmcblk0p3 - emmc - boot- 8000I SWITCH to ext4
<shineworld> # nandd - mmcblk0p5 - ext4 - system- 100000
<shineworld> # nande - mmcblk0p6 - ext4 - data - 100000
<shineworld> # nandf - mmcblk0p7 - emmc - misc- 8000I SWITCH to ext4
<shineworld> # nandg - mmcblk0p8 - ext4 - recovery- 10000
<shineworld> # nandh - mmcblk0p9 - ext4 - cache- 80000
<shineworld> # nandi - mmcblk0p10 - ext4 - databk- 80000
<shineworld> # nandj - mmcblk0p11 - vfat - UDISK- 428000
<shineworld> UDISK is usually a vfat disk for user data (mounted aka /mnt/sdcard
<DEac-> oh, there is a remapping? nanda -> mmcblk0p1
<shineworld> is mine remapping to run android 4.2.2 on SD card with A20
<shineworld> nand(x) are standard partitions in nand OS version
DropBear has joined #cubieboard
<DEac-> ok, i will try sudo nand-part -f a20 /dev/nand 32768 'bootloader 131072' 'rootfs 14778368'
<DEac-> if i lost data, i must retry it.
<tomboy64> mkad: it shows the usb-device is connected, it lists the usb-hd via lsusb, but no sg (scsi generic device), therefor no sdb (after my sata hd) is created and i can't access the hd
<tomboy64> mkad: it's linux (not android) and i've tried with 3 harddisks now. with and without external power.
Vanfanel has joined #cubieboard
<Vanfanel> Hi there
<tomboy64> mkad: and i do have an sata device connecte, which runs fine
wolfy has joined #cubieboard
n01 has quit [Remote host closed the connection]
<tomboy64> okay
<tomboy64> another question: compiling natively dies with: /usr/src/ct-linux-sunxi/arch/arm/mach-sun7i/pm/standby/pm_debug.h:4:23: fatal error: pm_config.h: No such file or directory
<tomboy64> compiling the kernel natively, that si
<tomboy64> suggestions for that?
<tomboy64> oh
<tomboy64> yeah
<tomboy64> that does NOT happen when i cross-compile
rcg_re has quit [Quit: WeeChat 0.4.2]
<wolfy> tomboy64: you are missing a devel lib
<wolfy> and headers
<mkad> sun7i is more powerful than sun4i ?
<shineworld> in some part
<shineworld> is more powerful , in others is minor
<shineworld> for what I know...
<shineworld> for example in FP is more fast
<tomboy64> wolfy: i'm not. copying the pm_debug.h into a subdirectory fixed it.
<mnemoc> the A23 is going to be quad-a7... hopefully they reuse sun7i and not spawning a new sun8i...
<mkad> thx
<mkad> mnemoc, I dont like cubietruck its too BIG
<mkad> bulky
<mkad> I wish I could have the same small cubieboard that fits into my plastic casing like cubieboard 1 but with A23 quad
<mkad> :)
<mnemoc> if A23 is feature related to the A13 it won't have lvds, hdmi or sata...
n01 has joined #cubieboard
<mkad> I dont need lvds and hdmi
<mkad> nor gpu
<mkad> I need super fast ARM mini computer)
<mkad> :)
<mkad> headless
<mkad> maybe this http://www.parallella.org/
<mkad> :)
RA3OR has quit [Read error: Connection reset by peer]
R430R has joined #cubieboard
shineworld has quit [Remote host closed the connection]
R430R has quit [Quit: RA3OR Script® v0.8]
RA3OR has joined #cubieboard
n01 has quit [Ping timeout: 240 seconds]
wolfy has quit [Ping timeout: 252 seconds]
ganbold_ has quit [Remote host closed the connection]
wav_ has joined #cubieboard
FR^2 has quit [Quit: und weg...]
smccarthy has quit [Remote host closed the connection]
wav_ has quit [Quit: Page closed]
Freyr has quit [Remote host closed the connection]
Freyr has joined #cubieboard
uizex1 has quit [Quit: Few women admit their age. Few men act theirs.]
jobsales has joined #cubieboard
jobsales has quit [Remote host closed the connection]
hramrach has quit [Remote host closed the connection]
hramrach has joined #cubieboard